Problem Install OpenMP 2.0.0

Problem Install OpenMP 2.0.0

Postby Gusvinhal » Wed Apr 12, 2017 2:50 pm

Hello everyone,

I trying install the OpenMP 2.0.0 on Parallella, but when I use de command make the follow error occurs:

epiphany.c:52:33: error: interrupt handlers cannot have arguments
void __attribute__((interrupt)) bar_wake_isr(int signum)

How can I resolve this?

Thank you very much!
Gusvinhal
 
Posts: 13
Joined: Thu Apr 06, 2017 6:35 pm

Re: Problem Install OpenMP 2.0.0

Postby jar » Wed Apr 12, 2017 3:24 pm

It's true that interrupts cannot have arguments. Change bar_wake_isr(int signum) to bar_wake_isr(void) in epiphany.c.

Likely, GCC didn't error for ISRs with unused arguments in the past.
User avatar
jar
 
Posts: 275
Joined: Mon Dec 17, 2012 3:27 am

Re: Problem Install OpenMP 2.0.0

Postby olajep » Thu Apr 13, 2017 8:37 am

I assume you are referring to OMPi 2.0.0 ?
http://paragroup.cse.uoi.gr/wpsite/news ... -0-is-out/

OMPi 2.0.0 is included in Parabuntu 2016.11.
A few modifications for it to work on Parabuntu 2016.3+ can be found in this tree:
https://github.com/parallella/ompi/tree/d9b5c54aa0a7

// Ola
_start = 266470723;
olajep
 
Posts: 121
Joined: Mon Dec 17, 2012 3:24 am
Location: Sweden


Return to OpenMP

Who is online

Users browsing this forum: No registered users and 1 guest

cron