Parallella Not Booting After ROM Flash

Forum about Parallella boot process, linux kernel, distros, SD-cards, etc.

Parallella Not Booting After ROM Flash

Postby Kalicutt » Wed Dec 30, 2015 10:24 pm

Hello,

I followed the guide here in order to flash the ROM on the Parallella: https://github.com/parallella/parallella-flash

I am using a Kickstarter Parallella which was running a custom version of the bitstream and kernel in order to run some additional modules, which was working fine. When using the flash image without making modifications to anything except the necessary compilations, the Parallella serial connection (which is currently my only access point) no longer works. I just get garbage when booting and then nothing else shows. When putting my custom FPGA bitstream and FSBL (unchanged from default after exporting to SDK) I get some activity, but it seems there is a problem with the U-Boot. The message below occurs and repeats.

...
U-Boot ...
...
power_init_board: Failed probing ISL9305 PMIC

resetting...


Any idea what is going on? I thought it was the U-Boot version since the branch was Parallella-Next, however when using Parallella-gen1 branch it did not even show this error message.

I need to customize an FSBL to enable voltage level shifters between the PS and PL, but it does not seem that this repository has the correct image for my board.
Kalicutt
 
Posts: 24
Joined: Mon Nov 30, 2015 3:57 pm

Re: Parallella Not Booting After ROM Flash

Postby Kalicutt » Fri Jan 08, 2016 2:08 pm

Fixed some device tree errors with the new configuration and this works fine now. I have a custom flash, custom bitstream, kernel, and devicetree.
Kalicutt
 
Posts: 24
Joined: Mon Nov 30, 2015 3:57 pm

Re: Parallella Not Booting After ROM Flash

Postby aolofsson » Fri Jan 08, 2016 6:38 pm

Well done!! If there were errors/omissions in documentation please consider submitting PR so that others don't have the same issues.
Andreas
User avatar
aolofsson
 
Posts: 1005
Joined: Tue Dec 11, 2012 6:59 pm
Location: Lexington, Massachusetts,USA


Return to Linux/U-Boot

Who is online

Users browsing this forum: No registered users and 1 guest