Parallella Wont Power On!!

Any technical questions about the Epiphany chip and Parallella HW Platform.

Moderator: aolofsson

Parallella Wont Power On!!

Postby carsenk » Tue Jul 08, 2014 9:05 pm

Hello!

I need some help guys! I recently got a Parallella board (16 core ephihany the zync 7010)

So I got it in the mail, didnt touch it until my power supply/micro-hdmi/micro-sd/usb hub/otg cable all came.

Today everything arrived! I carefully made sure to discharge myself and ground myself, then I proceeded to put together the Parallella with the Guexbox case, then I added the heartsink and then plugged everything in, then I go to plug the final and last step the power supply into it (A 5V 2amp Barrel Connector)......AND NOTHING...NO LIGHTS...NO POWER...NOTHING...

Did I receive a Dead on Arrival unit? Is there a switch somewhere that I am missing? Am I covered to get a new Parallella or what should I do? I tried unplugging all the other connectors and then plugging in the power and still nothing....

I do not have the money to just throw away $125 on my newly purchased Parallella! Someone please help me!
carsenk
 
Posts: 12
Joined: Tue Jul 08, 2014 9:00 pm

Re: Parallella Wont Power On!!

Postby FoxT » Tue Jul 08, 2014 9:26 pm

Maybe you just got a faulty power supply and there is no problem with the Parallella.
The first power adapter I bought for my Parallella was broken, which I could confirm with my wlan router that also uses 5V. Maybe you have some other device you could connect to the power supply to test it.
Additionaly make sure that the barrel connector is center positive. If not, your board could already have taken serious damage.
User avatar
FoxT
 
Posts: 4
Joined: Mon Dec 17, 2012 3:22 am

Re: Parallella Wont Power On!!

Postby carsenk » Tue Jul 08, 2014 9:32 pm

FoxT wrote:Maybe you just got a faulty power supply and there is no problem with the Parallella.
The first power adapter I bought for my Parallella was broken, which I could confirm with my wlan router that also uses 5V. Maybe you have some other device you could connect to the power supply to test it.
Additionaly make sure that the barrel connector is center positive. If not, your board could already have taken serious damage.


This is the power supply I purchased: http://www.amazon.com/gp/product/B00JEP ... UTF8&psc=1

I have been fiddling around with it, I got a 5V 2amp USB charging cable (I plugged it into the USB by the barrel connector on the parallella and no power) but I plugged it into the usb port by the micro-hdmi and i get a GREEN LIGHT ON! :) However, the OTG cable in the other microusb port does not work and HDMI does not display anything with the USB power..

The power supply is brand new straight from amazon prime....I will look around to see if I can test it with something...Maybe a USB Hub? (I do not use a router, I have unlimited 4G data from my phone that outputs a wifi hotspot).

P.S. Thanks for a quick reply!

EDIT: Still not getting power from the 5v 2amp power supply...
carsenk
 
Posts: 12
Joined: Tue Jul 08, 2014 9:00 pm

Re: Parallella Wont Power On!!

Postby FHuettig » Tue Jul 08, 2014 9:45 pm

Hi carsenk,

First (and easiest!) please check that there is a shorting block on J14. Unfortunately it's not marked, but J14 is the three-pin header next to the DC barrel connector and it should have the two pins nearest the barrel connector shorted together. It's possible that fell off during shipment.

Parallella-J14.jpg
J14
Parallella-J14.jpg (31.07 KiB) Viewed 7576 times


Otherwise, if you have a meter you can check the power supply and then with the PS connected to the board look for 5V on J14.

We'll get you working!

carsenk wrote:This is the power supply I purchased: http://www.amazon.com/gp/product/B00JEP ... UTF8&psc=1


Looks OK.

carsenk wrote:I got a 5V 2amp USB charging cable (I plugged it into the USB by the barrel connector on the parallella and no power) but I plugged it into the usb port by the micro-hdmi and i get a GREEN LIGHT ON! :) However, the OTG cable in the other microusb port does not work

In order to supply power through the USB port by the barrel connector you have to move the J14 jumper to the other position, otherwise it's not connected. The USB connector by the HDMI connector is not intended to power the board, though it may work. The USB connector by the DC connector is only for power.
-- Fred -- Hardware Guy --
FHuettig
 
Posts: 142
Joined: Wed Jan 29, 2014 8:30 pm
Location: Lexington, MA, USA

Re: Parallella Wont Power On!!

Postby carsenk » Tue Jul 08, 2014 9:50 pm

FHuettig wrote:Hi carsenk,

First (and easiest!) please check that there is a shorting block on J14. Unfortunately it's not marked, but J14 is the three-pin header next to the DC barrel connector and it should have the two pins nearest the barrel connector shorted together. It's possible that fell off during shipment.

Parallella-J14.jpg


Otherwise, if you have a meter you can check the power supply and then with the PS connected to the board look for 5V on J14.

We'll get you working!

carsenk wrote:This is the power supply I purchased: http://www.amazon.com/gp/product/B00JEP ... UTF8&psc=1


Looks OK.

carsenk wrote:I got a 5V 2amp USB charging cable (I plugged it into the USB by the barrel connector on the parallella and no power) but I plugged it into the usb port by the micro-hdmi and i get a GREEN LIGHT ON! :) However, the OTG cable in the other microusb port does not work

In order to supply power through the USB port by the barrel connector you have to move the J14 jumper to the other position, otherwise it's not connected. The USB connector by the HDMI connector is not intended to power the board, though it may work. The USB connector by the DC connector is only for power.



YOU ARE A HUGE HELP!

That is it! There is no J14 shorting block on my Parellella, I just double checked the case and there was nothing inside of it, (I recently purchased my Parellella from the small shop opening a couple weeks ago)..I also did not receive an SD card (which is okay I have a 32gb one all ready to go).

So how would I go about getting a shorting block? Anywhere local for an electronics shop? (Boise, Idaho)...Or is there another way to short it?

EDIT: So I found a small jumper block (off an old motherboard I had laying around)...Was able to put it on the parallella like the diagram above...So now it looks like ive got power! :) Green LED comes on and stays Solid with the power supply connected (USB hub/OTG cable seems to be working/powering a fan from usb)...

But now I am not able to see anything on the display...I had made an SD Card according to the setup guide (Ubuntu 14.04 Parallella with Zync 7010 GPIO/ FPGA)....but there is nothing at all displayed on my screen and the LED on the board stays solid green.
carsenk
 
Posts: 12
Joined: Tue Jul 08, 2014 9:00 pm

Re: Parallella Wont Power On!!

Postby FHuettig » Tue Jul 08, 2014 10:15 pm

carsenk wrote:That is it! There is no J14 shorting block on my Parellella,


Sorry about that! It must have had one to pass testing but apparently it fell off or was removed after that.

carsenk wrote:So how would I go about getting a shorting block? Anywhere local for an electronics shop? (Boise, Idaho)...Or is there another way to short it?


Those are rather common 0.1" shorting blocks. If you mess around with computers you may even have one as they are used for setting options on motherboards & disk drives, etc. But they are also available at radio shack (at least as long as Radio Shack is still available!). I see several 'shacks in Boise and they all show stock for that item.

That's the safest way, if you try to hack a connection with a piece of wire or a clip lead I'd be worried that the power might glitch and you could corrupt the SD card, not that it's impossible to re-load the sd card, just annoying.
-- Fred -- Hardware Guy --
FHuettig
 
Posts: 142
Joined: Wed Jan 29, 2014 8:30 pm
Location: Lexington, MA, USA

Re: Parallella Wont Power On!!

Postby carsenk » Tue Jul 08, 2014 10:53 pm

So I found a small jumper block (off an old motherboard I had laying around)...Was able to put it on the parallella like the diagram above...So now it looks like ive got power! :) Green LED comes on and stays Solid with the power supply connected (USB hub/OTG cable seems to be working/powering a fan from usb)...

But now I am not able to see anything on the display (HDMI)...I had made an SD Card according to the setup guide (Ubuntu 14.04 Parallella with Zync 7010 GPIO/ FPGA with Win32 Disk Imager and then copied the files over)....but there is nothing at all displayed on my screen with the Parallella all plugged in, usb working, hdmi seems to be working and detected by my hdmi switch (turns off when I turn off the parallella like it should) but nothing is displayed on the actual monitor (I also tried a direct connection, just goes into power saving mode like nothing is connected) and the LED on the board stays solid green the entire time.

I do not have an ethernet router to plug into, only wireless..I do have a Panda Wifi adapter hooked up to the Parallella though...
carsenk
 
Posts: 12
Joined: Tue Jul 08, 2014 9:00 pm

Re: Parallella Wont Power On!!

Postby carsenk » Wed Jul 09, 2014 3:55 am

Made another topic for the HDMI display not displaying anything: viewtopic.php?f=23&t=1463

Consider this topic solved :)...It powers up...which is pretty useless in my case until I get the display working ^^^
carsenk
 
Posts: 12
Joined: Tue Jul 08, 2014 9:00 pm


Return to Epiphany and Parallella Q & A

Who is online

Users browsing this forum: No registered users and 3 guests

cron