Poll: USB not working

Hardware related problems and workarounds

Are you unable to get USB working?

Total votes : 24

Poll: USB not working

Postby Sean S » Fri Jul 11, 2014 1:39 pm

It seems that a number of people are unable to get USB working on the board. The extent of the problem is not known so hopefully this poll will expose just how many are facing this issue. Please only vote once you have followed all the advice and checked that you are using the correct USB port, cables, power supply, image files, hubs (if you are using one) etc. I would like this to be an accurate reflection of true issue if it exists.

Thanks you to all that have shared their experience already and good luck to us in getting this issue resolved.
Sean S
Posts: 30
Joined: Mon May 19, 2014 5:30 pm

Re: Poll: USB not working

Postby over9000 » Fri Jul 11, 2014 6:01 pm

I voted 'yes', but I could equally have voted 'no'. I've also experienced problems with it sometimes not working. I thought I had everything set up and working before, but then when I came back and powered the machine on again later I was getting messages about a "sysfs interface" being deprecated and that many things "would be broken". This is with the official kernel and such. I went back to the kernel that was 9600's Debian image and that message disappeared, although I think that I still occasionally don't have working USB when I power up, necessitating a power cycle to clear the problem.
The quality of support here leaves an awful lot to be desired. I don't recall seeing even one official response to the problems that people have been reporting. I like your idea of a poll to raise awareness and hopefully get Adepteva to address the problem.
Posts: 98
Joined: Tue Aug 06, 2013 1:49 am

Re: Poll: USB not working

Postby e-rod » Fri Jul 11, 2014 6:18 pm

Agreed, I would suggest renaming the title to "USB sometimes not recognized on boot?" I voted yes because my USB did not work until I did the "micro USB cable" workaround.

I am curious how many people experience this. Basically, power-cycle your board 10 times and leave the USB device plugged in. Is it recognized every one of the 10 boots? If so, your board appears fine. If not, you have the issue we do.
Posts: 4
Joined: Fri Jul 11, 2014 3:26 am

Why I'm done with Adapteva

Postby perles » Fri Jul 11, 2014 8:52 pm

I voted NO because I don't need to power cycle 10 times to get my computer USB working, or boot it with a long USB cable if that's your case. Not even my Raspberry Pi needs it, it woks right on the first time for over years with daily usage! I am not sure that the idea of a poll is really important though. The thread of the USB issues is already 3x longer than the second ranking, which includes HDMI port not working. That means the USB is a big issue.

After a short discussion in USB not working thread I've applied for an RMA exchange, but because they took so long to approve emailed Adapteva support to know about it. I'm already aware that I have to pay the shipping expenses, and if they do not find the USB problem I have to either pay to ship it back or leave the $100 brick behind. Short after my RMA was approved I received an email from Diana South stating the following:
We have just issued you an RMA. Please be aware that we usually cannot reproduce these issues with long USB cables here. If the heat sink is attached to the chip, please leave it attached.

Fair enough :evil: if they will deliberately test the device with just the right cable having just the right impedance that will make my board work, it means they are not looking for to correct the issue but just hide it under the rug. The company silence on this issue is also another indication that something is roting. And this is why I'm done with Adapteva.

PS: I'm glad that my HDMI port works, at least I can have some use for it
Posts: 8
Joined: Fri Jun 20, 2014 4:28 pm

Re: Poll: USB not working

Postby Sean S » Mon Jul 14, 2014 4:03 pm

Hi Perles

I created this poll because I am constantly being told that the USB issue only affects a small number of people. And I am highly annoyed by this as you have clearly pointed out that the topic relating to USB problems has gained a significant amount of views which definitely points to it being an issue that affects most people.

I am tired of this issue being ignored and nothing being done. I would RMA my board but because I am in the UK, I don't see the point in forking out for the shipping - especially since this is a product defect. Also, that I am told that I cannot RMA the board because it was a gift and I would need to ask some poor soul to waste their time going through the process.

As far as I am concerned, I would expect Xilinx to get involved as it reflects poorly on them as Zynq is their product after all.

So, bottom line, I want Adapteva to fix this issue and stop brushing it under the carpet pretending that only a few people are affected.

Sean S
Posts: 30
Joined: Mon May 19, 2014 5:30 pm

Re: Poll: USB not working

Postby perles » Tue Jul 15, 2014 5:48 pm

Hi Sean,

I see your point but my experience with Forums and Polls is that not many participate, so the results of this poll may not reveal the magnitude of the problem. I think we should advise the community to properly test their boards before and answering the poll. I would suggest the following procedure, from which we can improve,
1 - Use the latest official release;
2 - Boot your board with a simple wired* mouse or keyboard
- do not do a software reset, unplug the power!
- make sure that the device you are plugging is working
- do not use USB hubs of any kind
3 - Repeat the item 2 a few times (3 or more times is suggested);
4 - If you have a your USB device working flawlessly every single time, then you have a good board
- If you do not have a USB device working at a times, then try to connect to your board using SSH and run lsusb
- If the result of the lsusb is 'unable to initialize libusb: -99' then you have a defective board
5 - The fact that the board can successfully boot sometimes does not mean that you have a fully functional board!

How about that?
Posts: 8
Joined: Fri Jun 20, 2014 4:28 pm

Re: Poll: USB not working

Postby AndrewStone » Wed Jul 16, 2014 2:32 pm

My board worked the first time, then lsusb gives code -99.

A polling tip: Never ask a question in the negative.

Or if you must, put the whole assertion in the answer:

Yes: my USB is broken
No: my USB is not broken
Posts: 4
Joined: Mon Jun 30, 2014 7:39 pm

Re: Poll: USB not working

Postby FHuettig » Wed Jul 16, 2014 6:55 pm

Hi all,

First, I want to assure everyone that we do take this issue seriously and are not trying to sweep anything under the rug. The hardware design was based on the zedboard which seemed like the best reference available. We have spent quite a bit of time on this and have also involved the author of the USB driver, he hasn't been able to help either. When the boards are built every one is tested by connecting it to a USB keyboard, mouse, and flash drive, every one of those peripherals must work or the board will not be shipped. Obviously we can't test every possible device nor can we take the time to make sure every board works a large number of times in a row, but USB is a standard plus we're using a PHY that comes from a reputable manufacturer and has been used with the Zynq in other systems, so it -should- work. Please understand we are as bothered by this as you are and if we could fix it with a simple change we would.

Here's my take, and I use these boards every day in different configurations plus I've looked at boards that have been sent back but seem to work when we get them. I don't think this has anything to do with "long" vs. "short" cables or any special "just right impedance" etc., I use different cables from 6" to 15' and they all work. When it fails the driver does not find the PHY at all, it's not just that it can't find a particular external peripheral. What I DO see consistently is that if you use the reset button OR power-cycle the board without waiting long enough then the OS will not be able to initialize USB and it won't work. I've tried this a lot and my experience is if the power has been off for at least 15 seconds then USB will come up every time. I say this as a recommendation not an official edict, but before you give up on your board please try it from power-on, using the latest SD image, and do not use the reset button. My guess is that something in the PHY or in the Zynq's USB module does not get reset properly from the reset signal, but it does come up as long as the power has been off long enough. That's as far as I can debug it for now, we'll see if there are changes in behavior with the upcoming new kernel & drivers and at that point I may have more visibilty into just what goes on during initialization.

One thing that made this problem much more prevalent in the past (by which I mean a month ago!) was that the OS used to often stall during initialization (the "Parallella perpetual penguin problem") which we tracked down to something not liking the default state of the UART RX line. When that line was pulled low (which it should be when nothing is connected, to indicate a "break" condition), and the UART was enabled as the default TTY, the OS would often hang during boot. The natural reflex in that case is to hit the reset button, which would then cause the USB failure when the OS did boot. We have since fixed that in the devicetree by removing the UART as the default console, and now I never see the PPPP any more. Since there is now rarely a need to reset the system (in my experience) then I dont' see USB problems any more. Other users have confirmed this, YMMV.

Again, just my $.02.
-- Fred -- Hardware Guy --
Posts: 142
Joined: Wed Jan 29, 2014 8:30 pm
Location: Lexington, MA, USA

Re: Poll: USB not working

Postby xilman » Wed Jul 16, 2014 9:28 pm

Posts: 80
Joined: Sat May 10, 2014 8:10 pm
Location: UK

Re: Poll: USB not working

Postby teekai » Sun Aug 10, 2014 9:24 pm

I purchased 2 boards thinking it would be fun to play around with it but up to this point I'm giving up on getting USB to work. I'm able to PuTTY in and install xrpd so I can remote in using windows client but it is soooooooo...........slow............I've tried hundreds of time with different combination of powered and unpowered USB hub and NO luck. I GIVE UP!
Posts: 10
Joined: Sat Aug 09, 2014 7:29 am


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 4 guests