Inconsistent Ethernet connection in headless mode

Hardware related problems and workarounds

Inconsistent Ethernet connection in headless mode

Postby Nimonm » Sun Jul 20, 2014 6:38 pm

I am seeing inconsistent Ethernet connection with my Parallella board running in headless mode. I downloaded the programming files as directed and the board does acquire an IP address from my router but I am not able to access the board (ping or ssh) most of the time. I have success maybe one in 20 tries.

I also see two modes of LED flashing on the Ethernet jack. One more is solid green with slow blinking orange. The other is rapid blinking on both. The mode is somewhat random from boot to boot. Any idea if either of these two modes is what I should be looking for?

As a fallback, I loaded the programming files with HDMI and USB enabled and connected to a monitor, keyboard, and mouse. With that setup, I was able to access the internet, ssh, and VNC into the board so I believe the hardware is not damaged. This is not a convenient setup so I don't want to run this way all the time.

Any suggestions on what the problem might be or how to get the headless version to boot reliably?

Thanks!
Nimonm
 
Posts: 1
Joined: Mon Dec 17, 2012 3:29 am

Re: Inconsistent Ethernet connection in headless mode

Postby arthurgarcete » Wed Jul 23, 2014 3:45 pm

Hi Nimonm,

I'm quite new in the Parallella community but never the less I was having the same problem, maybe this workaround could help you solve this problem.

First of all, I may tell you that I use Linux, therefore your experience may vary if you are using another OS.

This workaround consists basically in three steps:

  • Double check your Parallella network configurations (DHCP or STATIC IP) to see if it is consistent;
  • Perform a filesystem check on both partitions of Parallella SD card (BOOT and ROOTFS);
  • Remove the Parallella's 70-persistent-net.rules file
After having your Parallella SD card mounted in your computer and double checked your network configurations, type the following commands:

Check the BOOT filesystem partition (mounted):
Code: Select all
$ sudo fsck -a /dev/(parallella BOOT partition); #e.g. sdX1 or mmcblk0p1 for BOOT partition filesystem check.

Then umount the ROOTFS partition so it can be checked:
Code: Select all
$ sudo umount (your parallella ROOTFS mounted path); #e.g.  /media/$USER/rootfs
$ sudo fsck -a /dev/(parallella ROOTFS partition); #e.g. sdX2 or mmcblk0p2
$ sync;


Then try your parallella again, if that doesn't work, remove the PARALLELLA'S /etc/udev/rules.d/70-persistent-net.rules file with the following command:

Code: Select all
#e.g.
$ sudo rm /media/$USER/rootfs/etc/udev/rules.d/70-persistent-net.rules

Then execute the BOOT and ROOTFS filesystem check commands again to be sure.

Hope it helps :D.
Arthur Garcete

CELTAB Researcher - http://www.celtab.org.br
Rice Network Groups Visiting Scholar http://networks.rice.edu/
User avatar
arthurgarcete
 
Posts: 1
Joined: Wed Jul 23, 2014 2:53 pm
Location: Foz do Iguaçu, Paraná - Brasil

Re: Inconsistent Ethernet connection in headless mode

Postby tufei » Sun Jul 27, 2014 3:27 pm

I am having the same problem with the 16-core board. Although my experience is a bit better. I need to power-cycle the board 2-3 times before I can have one successful login in headless mode.

Removing the udev rule does not help at all.

The /etc/network/interfaces has only "auto lo" lines, "auto eth0" lines are commented out. I don't know how the network interface was brought up when that's disabled.

The output of `dmesg` does not contain lines related to eth0, only has "xemacps e000b000.eth: link up (100/FULL)" when I can remotely login.

I guess to get to the bottom, I'll need to diagnose with the serial console output.
tufei
 
Posts: 4
Joined: Sat Jul 05, 2014 3:05 pm

Re: Inconsistent Ethernet connection in headless mode

Postby ajtravis » Mon Jul 28, 2014 9:08 am

tufei wrote:I am having the same problem with the 16-core board. Although my experience is a bit better. I need to power-cycle the board 2-3 times before I can have one successful login in headless mode.

Removing the udev rule does not help at all.

The /etc/network/interfaces has only "auto lo" lines, "auto eth0" lines are commented out. I don't know how the network interface was brought up when that's disabled.

The output of `dmesg` does not contain lines related to eth0, only has "xemacps e000b000.eth: link up (100/FULL)" when I can remotely login.

I guess to get to the bottom, I'll need to diagnose with the serial console output.

Hi, tufei.

The NIC's are managed by "network-manager", unless there is an entry for the NIC in /etc/network/interfaces. If you uncomment the one for eth0 and reboot the NIC will no longer be managed by "network-manager", which is intended to be used to manage NIC's on a GUI desktop.

HTH,

Tony.
Minke Informatics Limited, Registered in Scotland - Company No. SC419028
User avatar
ajtravis
 
Posts: 160
Joined: Fri Jul 18, 2014 12:54 pm
Location: Scotland (UK)

Re: Inconsistent Ethernet connection in headless mode

Postby FHuettig » Wed Aug 13, 2014 6:49 am

Greetings,

Boot problems in headless mode could be related to a problem that occurs if nothing is connected to the UART pins. This problem is fixed in the GUI-mode devicetree but not in the available headless devicetree. If you are seeing this problem when nothing is connected to the UART pins, and especially if you don't see this problem when you DO have something connected to the UART, please see this post and let me know if it fixes your problem.
-- Fred -- Hardware Guy --
FHuettig
 
Posts: 142
Joined: Wed Jan 29, 2014 8:30 pm
Location: Lexington, MA, USA

Re: Inconsistent Ethernet connection in headless mode

Postby shodruk » Wed Aug 13, 2014 9:35 am

FHuettig wrote:Greetings,

Boot problems in headless mode could be related to a problem that occurs if nothing is connected to the UART pins. This problem is fixed in the GUI-mode devicetree but not in the available headless devicetree. If you are seeing this problem when nothing is connected to the UART pins, and especially if you don't see this problem when you DO have something connected to the UART, please see this post and let me know if it fixes your problem.


Thanks Fred,
I think you (Adapteva) should note to the create-sdcard page or add FAQ in the Quickstart guide.
Shodruky
shodruk
 
Posts: 464
Joined: Mon Apr 08, 2013 7:03 pm

Re: Inconsistent Ethernet connection in headless mode

Postby Morgaine » Thu Aug 14, 2014 2:43 pm

FHuettig wrote:Boot problems in headless mode could be related to a problem that occurs if nothing is connected to the UART pins. This problem is fixed in the GUI-mode devicetree but not in the available headless devicetree.


I'm sure it would help those who are experiencing this problem if an ETA were given for when the fix will be released for the headless devicetree, or alternatively, detailed information on the root cause of the problem and how to fix it themselves.

Morgaine.
Morgaine
 
Posts: 42
Joined: Tue Jul 02, 2013 8:29 pm


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests