Power Adapter issues

Hardware related problems and workarounds

Power Adapter issues

Postby Masafumi Ohta » Sat Jul 26, 2014 5:03 am

Hello,

I met AC power adapter issue on Parallella now have figured out and fixed the issue.hope my process for fixing the issue is useful for you users.

First time I received Actiontec MI424WR (it is for wireless router ?) AC Adapter as a part of package (HDMI,USB Cables,AC Adapter,MicroSD Card) from Adapteva.

http://www.jameco.com/webapp/wcs/stores/servlet/Product_10001_10001_2082222_-1

First time I won't boot..I tried many times to power on-off the board..some times succeed booting or other time are not.
I contacted the Parallella support to fix the issue.and I asked a Linaro guy who wellknow ARM specific issue.Checking logs I have taken it reboots again and again a way of process while booting and CR10 LED blinking whenever fails boot.(often stop blinking and then start lighting to boot but after a bit while LEDs on Ethernet connecter start blinking,the CR10 LED stop lighting and then start blinking - fails booting).The support said it would caused by the AC adapter and the Linaro guy also said ARM CPUs need proper and reliable AC resources for the boards working and he gave me advices - I should choose the reliable and stable AC adapter and ask the support to replace the wrong adapter.

I looked for the AC adapter with the search listings - I checked the Adafruit AC adapter in this forum but would take a while to get it here in Japan...

http://www.parallella.org/forums/viewtopic.php?t=1001&p=6335

Checking description above the site PSP Adapter might be useful for Parallella it is very expensive though (cost me 30US$) I bought the adapter and the plug adapter (od 4.0→5.5) connecting Parallella.

PSP AC Adapter
http://www.jp.playstation.com/psp/peripheral/psp100.html

Plug Adapter
http://item.rakuten.co.jp/denshi/53099/

Then I tried the evaluation with 3 adapters as follows:

[Parallella] - [ AC Adapter ] - [ Watt Checker ] - [AC Consent ]
| |
[HDMI] [USB]

I've tried 3 cases withe Latest OS (14.04LTS and latest Kernel with HDMI Support) and I use SANWA watt monitor ( see http://www.sanwa.co.jp/product/syohin.asp?code=tap-tst8 for more detail)

1.Wrong adapter
2.AC Adapter Adapteva has shipped in replace of wrong one.
3.Sony-Branded PSP Adapter (PSP-100) + 5.0mm OD 2.1mm ID Connector

When I use Wrong Adapter ,the Watt checker says 9.2-9.7 (max 13.2) watts when it tries to boot but fails to make it.
When I use AC Adapter ,the watt checker says 6.2-6.7 watts when it tries to boot and then succeeds booting.
When I use Sony-Branded PSP Adapter the watt checker says 5.8-6.7 watts when it tries to boot and then succeeds booting.(most fit to use it - it is very reliable adapter by Sony! )

That's all - now works fine with PSP Adapter :) hope my report is useful for Parallella users.
Last edited by Masafumi Ohta on Sat Jul 26, 2014 1:05 pm, edited 1 time in total.
User avatar
Masafumi Ohta
 
Posts: 3
Joined: Fri Jul 11, 2014 11:29 am
Location: Tokyo,Japan

Re: Power Adapter issues

Postby ajtravis » Sat Jul 26, 2014 12:07 pm

Masafumi Ohta wrote:Hello,

I met AC power adapter issue on Parallella now have figured out and fixed the issue.hope my process for fixing the issue is useful for you users.
[...]
That's all - now works fine with PSP Adapter :) hope my report is useful for Parallella users.

Hi, Masafumi.

I'm using one of these to power my 4@A101020 Parallella boards:
http://www.maplin.co.uk/p/maplin-84a-usb-charging-station-n41dn

Might be useful for other people looking for a UK PSU for the Parallella cluster kit.

HTH,

Tony.
Minke Informatics Limited, Registered in Scotland - Company No. SC419028
User avatar
ajtravis
 
Posts: 160
Joined: Fri Jul 18, 2014 12:54 pm
Location: Scotland (UK)

Re: Power Adapter issues

Postby Masafumi Ohta » Sun Oct 26, 2014 4:21 pm

I have blogged 'Design Spark' RS Users community about the power issue in Japanese about to getting started releasing Rarallella by RS Japan(Sorry Japanese Only it is for Japanese Parallella prospective users)

http://www.rs-online.com/designspark/electronics/eng/blog/content-1032?/designspark/electronics/blog/content-1032=
User avatar
Masafumi Ohta
 
Posts: 3
Joined: Fri Jul 11, 2014 11:29 am
Location: Tokyo,Japan


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests