Can not boot parallella board

Hardware related problems and workarounds

Can not boot parallella board

Postby willf » Mon Sep 08, 2014 8:48 pm

Dear Parallella users,
I would appreciate your assistance please in getting my new parallella board up and running.
I have been following this github parallella ubuntu guide https://github.com/parallella/parallella-ubuntu
I am however stuck at step #9. "First boot (with screen/keyboard/mouse or serial port attached)"
I don't have access to a serial port cable. I do have a monitor and use micro-hdmi to hdmi cable and a hdmi to DVI adapter.
I'm assuming although not specified in the instructions on this webpage, I need to download the kernel with HDMI support.
For instructions on this I have referred to http://www.parallella.org/create-sdcard/ and carried out step#5. Having completed this step and unmounted my SD card from my host PC, I've put the micro-SD card in the Parallella board.
When I connect the power to my Parallella board (with the micrcoSD card in place, network cable, keyboard micro-hdmio cable connected etc.) nothing happens. The green LED for the power is and network is on, There is no green LED for the HDMI.
I'm not sure what I'm doing wrong (obviously missing some step).
Your help would be sincerely appreciated.

Thank you in advance,
Regards,
Will.
willf
 
Posts: 11
Joined: Mon Jul 28, 2014 2:49 pm

Re: Can not boot parallella board

Postby gceline » Mon Sep 08, 2014 9:10 pm

Two LEDs should light up on the board - CR8 first and CR10 second (unless you have an A101040 SKU - then CR10 will not light)
This will happen with or without an SD Card. Once you have the SD card, then the Ethernet leds will come on as well. If the boot is succesful, the card wil request an IP address from the router and you should be able to ping and SSH to the board.
The most common problem in boot is the last step - getting the correct images into the BOOT partition - make sure you have the uImage, the devicetree and the parallella.bit.bin file (this has top be renamed!)

The HDMI may be having issues if you are using an HDMI to DVI converter, not every monitor we have tested has given us perfect results - if you have an native HDMI monitor it will work.
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Can not boot parallella board

Postby willf » Mon Sep 08, 2014 9:52 pm

Thank you for your reply Graham.

I have in my BOOT partition,the uImage,devicetree.dtb and parallella.bit.bin

I don't have a HDMI monitor. It should be possible I guess to login remotely (over network) to parallella board.

To be honest I can't remember if I have the A101040 SKU, but am sure that only one LED lights up.

Regards,

Will.
willf
 
Posts: 11
Joined: Mon Jul 28, 2014 2:49 pm

Re: Can not boot parallella board

Postby willf » Tue Sep 09, 2014 1:14 pm

Graham,

Checked my Parallella boad model number, it's SKU P1602-DK02. I guess both CR8 and CR10 should be green when powered up and working. Only CR8 is on.
I have tried several methods to install the necessary files on the micro-SD card and to get the parallella board to boot up and work but I am having no luck.
I tried doing it through Windows OS using Dr Beau Webber's "A beginners guide to getting started with the Parallella". This did not help either. Still nothing.
I did see on the forum
After you burned the SD Card (in Windows), you see a Partition on the SD Card called BOOT, which is empty.
Rename the FPGA bitfile and copy it to that BOOT Partition as mentioned in the guide.
Then unpack kernel-hdmi-default.gz - you get (with 7zip) "kernel-hdmi-Default". Open this with 7Zip again and you see "devicetree.dtb" and "uImage". Drag and drop these files to the BOOT Partition as well.

My partition certainly was not empty. I did try and copy the contents of the of the linux kernel with HDMI support and FPGA file etc. as detailed on this page http://www.parallella.org/create-sdcard/ but this didn't help either. Can it be so difficult to get this working? Could I possibly have a dud parallella board? Very frustrating.
Any further thoughts, assistance would be appreciated.
Thanks in advance.
Regards,
Will.
willf
 
Posts: 11
Joined: Mon Jul 28, 2014 2:49 pm

Re: Can not boot parallella board

Postby gceline » Wed Sep 10, 2014 12:25 pm

If the second LED is not lighting this is not good - the board will have to be replaced (To clarify for future readers - this is only true for newer models with SKU P160x... - we changed the programming of the flash. Earlier SKUs A1010xx will not light the second LED)

Please request an RMA from wherever you purchased and contact support@adapteva.com if you have any issues.
Sorry about this!
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Can not boot parallella board

Postby willf » Wed Sep 10, 2014 10:21 pm

Yes, these were my thoughts also.

I have contacted the Parallella board supplier/distributor in the UK (RS electronics-components) and they are going to send me out a replacement board. They don't have any in stock for a few weeks, so I just got to wait, which is a shame.

Hopefully I'll have better luck next time around.

Regards,

Will.
willf
 
Posts: 11
Joined: Mon Jul 28, 2014 2:49 pm


Return to Troubleshooting

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron