Cant find Headless Parallella in my network

Hardware related problems and workarounds

Cant find Headless Parallella in my network

Postby danbru1211 » Fri Oct 17, 2014 10:07 pm

First I created the SD card from Windows and connected my new headless parallella to my router. This router has a webinterface to show IPs of connected device. Parallella does not show up (I also tried other tools, I know how to find devices in my network :P).

I removed all partitions on the sd card from ubuntu and created the sd card again (from ubuntu). Same result in finding the device in my network.

Now I edited the /etc/network/interfaces on the sd card to set a fixed ip and netmask, but I still cant connect to my parallella!

The two greed LEDs and network LEDs show up with and without SD card. Is this normal? Who activates LAN when there is no sd card inserted?

I have these Files on the FAT Partition:
    devicetree.dtb (from kernel-headless-default)
    uImage (from kernel-headless-default)
    parallela.bit.bit (named berfore renaming: parallella_e16_headless_gpiose_7010.bit.bin, also tried the 7020 variant)

Is my board the problem?
danbru1211
 
Posts: 5
Joined: Thu Sep 25, 2014 12:09 pm

Re: Cant find Headless Parallella in my network

Postby gceline » Sat Oct 18, 2014 3:39 pm

IS this a typo or did your mean parallela,bit.bit???
it should be parallella.bit.bin

two Ls and bin at the end!

Just make sure you have the right file for the board - trying the wrong one is not going to work and only can cause confusion.
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Cant find Headless Parallella in my network

Postby gceline » Sat Oct 18, 2014 3:39 pm

IS this a typo or did your mean parallela,bit.bit???
it should be parallella.bit.bin

two Ls and bin at the end!

Just make sure you have the right file for the board - trying the wrong one is not going to work and only can cause confusion.
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Cant find Headless Parallella in my network

Postby mjanderson235 » Mon Oct 20, 2014 1:13 am

I've been having the exact same problem as danbru1211 - the two green lights on the side of the board, along with both the green and amber lights on the ethernet port, show up with or without the SD card. The card itself would seem to have all the appropriate files (devicetree.dtb, uImage, parallela.bit.bin, everything taken from headless installs).

I can't find the board, whether I directly connect it with an ethernet cable, used a closed network with a router, or plug it into my normal wireless router. When I take the SD card out to check the files in /var/log, nothing has been written (and I made sure to change the file permissions to a+rw on the log files, just to make sure that wasn't causing a problem).

I'm waiting for cables and peripherals to connect it up via other means (didn't have either an HDMI monitor or USB keyboard), but it looks like the networking is supposed to work out of the box from what I've been seeing - is that correct? Or is it absolutely necessary via serial to start interacting with the board?

Thanks in advance for any help!
mjanderson235
 
Posts: 4
Joined: Mon Oct 20, 2014 1:04 am

Re: Cant find Headless Parallella in my network

Postby gceline » Mon Oct 20, 2014 10:44 pm

mjanderson235 You have the same spelling error as danbru1211 in your post
if the file is really named parallela.bit.bin then it will not boot

parallella.bit.bin ----- double l, double l

The serial will only help you see the error messages if it is not recognizing the file - but if the baord is not showing up on the network, 99% chance the board is not booting because of an error with the SD card.
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Cant find Headless Parallella in my network

Postby mjanderson235 » Mon Oct 20, 2014 11:15 pm

Sorry, my mistake - it is named correctly on the SD card, my keyboard here just hates double letters.

What would an error with the SD card entail? It's a perfectly new card which works fine on my laptop running Ubuntu, a Patriot 32 gig Class 10.
mjanderson235
 
Posts: 4
Joined: Mon Oct 20, 2014 1:04 am

Re: Cant find Headless Parallella in my network

Postby gceline » Tue Oct 21, 2014 12:26 am

The card could be bad, we recommend Sandisk because these rarely fail. However - the initial process is totally dependent on the BOOT partition having the correct files and the unit identifying these correctly

File 1:
parallella_e16_headless_gpiose_7010.bit.bin (2035 kb)
RENAMED as parallella.bit.bin

File 2
devicetree.dtb 3/6/14 7kb
File 3
uImage 2/6/14 4368kb

These are in the file kernel-headless-default.tgz (4343 kb zipped) and need to be extracted first.
Copy these cleanly - delete old versions, unplug the SD card, re-insert and make sure the old files are no longer there, and then copy/paste the files into the directory.

You should be good to go.
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA

Re: Cant find Headless Parallella in my network

Postby mjanderson235 » Wed Oct 22, 2014 12:05 am

Nope, still not working. Went out and got a Sandisk 16 gig, burned it, tested it on a couple different Linux computers (which vetted my Patriot disk too, so the disk itself doesn't seem to be bad), still won't work. File names, dates, and sizes have been checked and rechecked. Disks have been formatted a couple times too, to make sure.

All the lights come on, the amber light on the ethernet port looks like it's doing something, I just can't find an IP address no matter what. And nothing's being written to var/log, either.
mjanderson235
 
Posts: 4
Joined: Mon Oct 20, 2014 1:04 am

Re: Cant find Headless Parallella in my network

Postby mjanderson235 » Wed Oct 22, 2014 1:01 am

Ok, problem solved! There's something wrong with the headless files - when I switched to the HDMI ones (even though using a headless configuration), everything worked fine.
mjanderson235
 
Posts: 4
Joined: Mon Oct 20, 2014 1:04 am

Re: Cant find Headless Parallella in my network

Postby gceline » Wed Oct 22, 2014 1:08 am

Great - will try and work out what is the issue with the files
Graham
Adapteva
gceline
 
Posts: 119
Joined: Wed Jul 31, 2013 12:06 pm
Location: Lexington, MA


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests