Can't seem to SSH into board

Hardware related problems and workarounds

Can't seem to SSH into board

Postby aaronchien » Sat Nov 01, 2014 8:02 pm

I've been trying to find the IP address of my board for the past day, and I can't find it using the Advanced IP Scanner. It worked a week ago but I'm not sure why it isn't working now. The two green LEDs light up, the ethernet lights light up as well. I've cleaned the SD card and reformatted it multiple times, but I just can' t seem to find the MAC ID on the scanner.

Why is this happening, and are there any possible solutions to this issue?

Thanks.
aaronchien
 
Posts: 1
Joined: Thu Oct 23, 2014 3:47 am

Re: Can't seem to SSH into board

Postby 9600 » Sun Nov 02, 2014 4:57 pm

Have you tried logging in to your router to see if it is being leased a DHCP address?

Can you attach a keyboard, monitor and mouse, log in that way and take a look around?

Failing the above, take the SD card out, mount the root filesystem on another machine and examine the log files in /var/log.

Regards,

Andrew
Andrew Back (a.k.a. 9600 / carrierdetect)
User avatar
9600
 
Posts: 997
Joined: Mon Dec 17, 2012 3:25 am

Re: Can't seem to SSH into board

Postby yanidubin » Mon Nov 03, 2014 10:58 am

aaronchien: I would suggest, if you can find your way around Wireshark, and are using a non-switched hub, I recommend you monitor for BOOTP protocol messages (DHCP).

This is a direct way to scan for "signs of life", which an IP scanner cannot give you. If you want to know why it is not getting an IP (a requirement for an IP scanner to tell you anything useful at all), this will allow you to eliminate DHCP service issues versus the board not requesting an address at all.
User avatar
yanidubin
 
Posts: 95
Joined: Mon Dec 17, 2012 3:23 am
Location: Christchurch, New Zealand


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests