[SOLVED] Parallella 16 won't boot with 15.04

Hardware related problems and workarounds

[SOLVED] Parallella 16 won't boot with 15.04

Postby mchampigny » Tue Dec 13, 2016 3:34 am

I'm trying to boot the Parallella for the first time using 15.04 HDMI version and I cannot get it working.

Here's a summary of what's going on...

I see three green LEDs lit up on the board itself, all steady.
Ethernet. Green LED comes on for a few seconds, then the orange LED flashed continuously (forever apparently...).
USB micro to USB adapter with wireless dongle connecting a keyboard/touchpad combo.
HDMI micro to HDMI connected. I see a white underscore character in the top left and nothing more...ever. No boot messages, but the monitor at least thinks it has a valid HDMI connection.
Power supply (the one the Parallella 16 came with).
16GB microSD with 15.04 HDMI version for my board: Zynq 7010 version.

I cannot see the MAC address from my router and I could not find an IP with a port scan. I have no way to SSH into the board or to see boot message (I don't have a serial cable).

I tried the same setup with various alternate cables and microSD cards of various brands and sizes. Nothing works.

Any ideas on what I can do short of buying a serial cable and debugging it from there?

Thanks,
Michael
mchampigny
 
Posts: 27
Joined: Fri Dec 02, 2016 2:56 am

Re: Parallella 16 won't boot with 15.04

Postby sebraa » Tue Dec 13, 2016 1:07 pm

mchampigny wrote:Any ideas on what I can do short of buying a serial cable and debugging it from there?
Nothing. You don't know what's going on, so any further steps rely on gathering knowledge. Which requires access to a serial cable, bought or not.
sebraa
 
Posts: 495
Joined: Mon Jul 21, 2014 7:54 pm

Re: Parallella 16 won't boot with 15.04

Postby aolofsson » Tue Dec 13, 2016 1:38 pm

90% of the time, the problem is not burning the SD card correctly (that includes me!)
Just to verify I picked a new HDMI monitor I had and a new P1601 card. No problem with the new image.
User avatar
aolofsson
 
Posts: 1005
Joined: Tue Dec 11, 2012 6:59 pm
Location: Lexington, Massachusetts,USA

Re: Parallella 16 won't boot with 15.04

Postby aolofsson » Tue Dec 13, 2016 2:53 pm

just in case you don't believe me... ;)
(btw, for the record, USB on a randomly sampled board came up 2/2 with new image)

Setup:
DELL monitor, 1920x1200 resoluion (hdmi input)
unpowered micro-->USB dongle
K330 logic vision wireless keyboard/mouse
Attachments
20161213_090010.jpg
20161213_090010.jpg (1.65 MiB) Viewed 4306 times
User avatar
aolofsson
 
Posts: 1005
Joined: Tue Dec 11, 2012 6:59 pm
Location: Lexington, Massachusetts,USA

Re: Parallella 16 won't boot with 15.04

Postby mchampigny » Tue Dec 13, 2016 8:10 pm

I suspect it's my USB microSD reader/writer that is misbehaving. I was wondering why dd seemed to run so quickly.
I'll pick up a new reader/writer adapter and create another image to see how that goes and will report back.
mchampigny
 
Posts: 27
Joined: Fri Dec 02, 2016 2:56 am

Re: Parallella 16 won't boot with 15.04

Postby mchampigny » Thu Dec 15, 2016 1:29 am

I tried a new microSD reader/writer and this time burned the image on a Mac. I mounted the image and the boot partition looked fine.
However, I still cannot bring up the Parallella. The HDMI now kicks out instead of showing the "_" character in the top left of the screen.
And now the ethernet port green light stays on and the orange light never comes on.

I cannot see the board MAC address from my router.

I ordered a serial cable to debug this, but I fear the board may be dead. It's odd, because I can see the 3 green LEDs lit on the board which should indicate it's healthy.
mchampigny
 
Posts: 27
Joined: Fri Dec 02, 2016 2:56 am


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests