CLUSTER: FRAMEBUFFER AND VIDEO OUTPUT USING LXSESSION

CLUSTER: FRAMEBUFFER AND VIDEO OUTPUT USING LXSESSION

Postby claudio4parallella » Wed Sep 12, 2018 2:32 pm

Hi,
I'm going to some slow progress on my needs.

MY SCENARIO
- Cluster of 4 parallellas, 64 core, via eLink; 3 SLAVE parallellas, 1 MASTER parallella
- Mandatory usage of old img ubuntu-14.04-headless-z7010-20150130.1.img , the only capable of make working eLink Custer
- The Cluster application produce a PNG file
- Installing lxde, ok graphic desktop with VNC, may be useful for GTK graphic applications

MY MISSING
- No existing Framebuffer /dev/fb0 using ubuntu-14.04-headless-z7010-20150130.1.img
- No existing Video Output, no HDMI using ubuntu-14.04-headless-z7010-20150130.1.img
- No possibility to use the last IMG with HDMI / Framebuffer with the Cluster

MY NEEDS
- I need to output the bitmap produces by the fast 64 cores cluster immediately to a video, using for example the Framebuffer and "lxsession" or "framebuffer-vncserver": using a Raspberry Pi I use to display bitmap on my MAC directly written into the Framebuffer /dev/fb0

MY WAYS
**BOOT** : I've put the HDMI BOOT files: devicetree.dtb and uImage I got at http://downloads.parallella.org//boot/linux/kernel-hdmi-140603.tgz in place of the ubuntu-14.04-headless-z7010-20150130.1.img original headless boot files.
**RESULTS**: 1) The Framebuffer /dev/fb0 is generated; framebuffer is working succesfully write into; 2) no way to run "lxsession" or "framebuffer-vncserver" and show my bitmap generated by the 64 cores cluster 3) Epiphany sdk is not working at all.
May be the uImage or bitsteream is not compatible with epiphany and esdk

MY CONCLUSIONS:
- even if I've succesfully setup the Framebuffer, I've not the results of video output of bitmap within the Headless system.

Any Further Suggestion?
Thanks in advance
claudio4parallella
 
Posts: 60
Joined: Thu Aug 10, 2017 3:48 pm

Return to Clustering

Who is online

Users browsing this forum: No registered users and 1 guest